サブネット計算ツール — IPv4・IPv6 の CIDR、VLSM、重複チェック

任意の CIDR のネットワーク、ブロードキャスト、ホスト範囲、マスクを計算。VLSM でのネットワーク分割、IPv6 の展開、範囲の重複チェックもできます。

192.168.1.130/26、10.0.0.1 255.255.0.0、またはアドレスのみ(/32)。
ネットワーク
192.168.1.128/26
使用可能なホスト数
62
64 アドレス
サブネットマスク
255.255.255.192
ネットワークアドレス192.168.1.128
ブロードキャストアドレス192.168.1.191
最初の使用可能ホスト192.168.1.129
最後の使用可能ホスト192.168.1.190
使用可能なホスト数62
総アドレス数64
サブネットマスク255.255.255.192
ワイルドカードマスク0.0.0.63
CIDR 表記192.168.1.128/26
IP クラス(旧方式)C
アドレスの種類プライベートネットワーク (RFC 1918)

最初のアドレスはネットワークを識別し、最後のアドレスはブロードキャストアドレスなので、どちらもホストには割り当てられません。 192.168.1.130 は 192.168.1.128/26 内のホストです。ネットワークアドレスは 192.168.1.128 です。

2 進数
アドレス          11000000.10101000.00000001.10000010
マスク            11111111.11111111.11111111.11000000
ネットワーク      11000000.10101000.00000001.10000000
ブロードキャスト  11000000.10101000.00000001.10111111
先頭の 26 ビットがネットワーク部で、残りの 6 ビットがホストの番号です。

すべてブラウザ内で動作します。入力したアドレスがどこかに送信されることはありません。 すべての無料ツールを見る.

不具合や改善できそうな点を見つけましたか?いただいたメッセージはすべて読み、すぐに対応します。

このサブネット計算ツールは、任意の IPv4 CIDR ブロック、または IP アドレスとマスクについて、ネットワークアドレス、ブロードキャストアドレス、使用可能なホスト範囲、ホスト数、サブネットマスク、ワイルドカードマスクを計算し、2 進数での内訳と、その範囲がプライベート、パブリック、予約済みのどれかを表示します。/31 のポイントツーポイントリンクは RFC 3021 に従い(使用可能なアドレスは 2 つ、ブロードキャストなし)、/32 は単一のホストとして扱います。

ネットワークの計画もできます。ブロックを均等なサブネットに分割したり、VLSM で異なるサイズのサブネットを割り当てたりして、計画を CSV でエクスポートできます。IPv6 では、アドレスを RFC 5952 の正規形式で展開・圧縮し、任意のプレフィックスの範囲とサイズを表示します。重複チェックでは、VPC、VPN、オフィスの範囲などの CIDR のリストを受け取り、どれが衝突しているかを報告します。計算はすべてブラウザ内で行われます。

使い方

  1. プレフィックス付き(192.168.1.130/26)またはマスク付き(192.168.1.130 255.255.255.192)でアドレスを入力します。結果は入力に合わせて更新されます。プレフィックスのメニューで他のサイズも試せます。
  2. サブネットを計画するには「分割 / VLSM」を開き、親ネットワークと、サブネットの数、サブネットあたりのホスト数、またはサブネットごとに名前とホスト数を 1 行ずつのいずれかを入力します。
  3. IPv6 では「IPv6」タブを開き、任意の形式のアドレスを、必要なら /プレフィックス付きで入力します。
  4. 衝突を確認するには「重複チェック」を開き、1 行に 1 つずつ CIDR を貼り付けます。
  5. 概要をコピーするか、サブネット計画を CSV でダウンロードします。

よくある質問

/24、/25、/26… の使用可能なホスト数は?

使用可能なホスト数 = 2^(32 − プレフィックス) − 2 です。最初のアドレスがネットワーク、最後がブロードキャストになるためです。/24:254、/25:126、/26:62、/27:30、/28:14、/29:6、/30:2。/31 はポイントツーポイントリンクで使用可能なアドレスが 2 つ(RFC 3021)、/32 は 1 ホストです。クラウドプロバイダーはさらに多くを予約します。AWS はサブネットごとに 5 アドレス、Azure も 5 アドレスを確保するので、AWS の /24 で使用可能なのは 251 アドレスです。

ワイルドカードマスクとは何ですか?

サブネットマスクをビットごとに反転したもので、255.255.255.0 は 0.0.0.255 になります。Cisco のアクセスリストや OSPF の network コマンドではワイルドカードマスクを使い、0 のビットは「一致が必要」、1 のビットは「任意の値」を意味します。連続したマスクなら、ワイルドカードは各オクテットを 255 から引くだけで求められます。

プライベートな IP の範囲はどれですか?

RFC 1918 は、10.0.0.0/8、172.16.0.0/12(172.16.0.0〜172.31.255.255)、192.168.0.0/16 をプライベートネットワーク用に予約しています。ほかにも、キャリアグレード NAT 用の 100.64.0.0/10(RFC 6598)、ループバックの 127.0.0.0/8、リンクローカルの 169.254.0.0/16、ドキュメント用の 192.0.2.0/24、198.51.100.0/24、203.0.113.0/24 はパブリックにルーティングされません。IPv6 では、fc00::/7(実際には fd00::/8)がプライベートなユニークローカルの範囲です。

VLSM とは何ですか?

可変長サブネットマスク(Variable Length Subnet Masking)とは、ネットワークを均等ではなく異なるサイズのサブネットに分割することで、同じブロックから、100 ホストの LAN には /25 を、ルーター間のリンクには /30 を割り当てられます。ここで使っている標準的な方法では、要求を大きい順に並べ、それぞれに収まる最小の 2 のべき乗のブロックを割り当てるので、すべてのサブネットが自身の境界に揃います。

/31 に使用可能なホストが 2 つあるのはなぜですか?

ポイントツーポイントリンクには機器が 2 台しかないので、ネットワークアドレスとブロードキャストアドレスは無駄になります。RFC 3021 は、両方のアドレスを両端に割り当てる /31 のサブネットを認めています。ほとんどのルーターと Linux が対応しており、/30 と比べてリンクでのアドレス使用量が半分になります。

IPv6 の /64、/56、/48 はどれくらいの大きさですか?

/64 は IPv6 の単一サブネットの標準サイズで、2^64(約 1,844 京)個のアドレスを含みます。SLAAC にはちょうど /64 が必要です。家庭の回線には通常 /56(/64 のサブネット 256 個)か /64 が、組織には /48(/64 のサブネット 65,536 個)が割り当てられます。IPv6 の計画は、アドレスではなく /64 のサブネットの数で考えます。

IPv4 サブネット早見表

• /8 — 255.0.0.0 — 16,777,214 ホスト

• /16 — 255.255.0.0 — 65,534 ホスト

• /20 — 255.255.240.0 — 4,094 ホスト

• /22 — 255.255.252.0 — 1,022 ホスト

• /23 — 255.255.254.0 — 510 ホスト

• /24 — 255.255.255.0 — 254 ホスト

• /25 — 255.255.255.128 — 126 ホスト

• /26 — 255.255.255.192 — 62 ホスト

• /27 — 255.255.255.224 — 30 ホスト

• /28 — 255.255.255.240 — 14 ホスト

• /29 — 255.255.255.248 — 6 ホスト

• /30 — 255.255.255.252 — 2 ホスト

• /31 — 255.255.255.254 — 2(ポイントツーポイント、RFC 3021)

• /32 — 255.255.255.255 — 1(単一ホスト)

クラウドと VPN のアドレス空間を計画する

クラウドプロジェクトのネットワークのトラブルの多くは、範囲の重複が原因で、2 つのネットワークをピアリングしたり VPN で接続したりする段階になって初めて発覚します。VPC や VNet を作る前に、将来つながる可能性のあるすべての範囲を書き出しましょう。他の VPC、オンプレミスのオフィス、VPN クライアントのプール、Kubernetes のポッドとサービスの CIDR、Docker のデフォルトブリッジ(172.17.0.0/16)です。それらを重複チェックにかけ、どれとも衝突しないブロックを選びます。

リモートユーザーが VPN で接続するものには、192.168.0.0/24 と 192.168.1.0/24 を避けましょう。ほとんどの家庭用ルーターがこれらを使っているためです。環境ごとに大きなブロックを割り当て(たとえば 10.0.0.0/8 からリージョンごとに /16)、VLSM で分割すれば、後から番号を振り直さずにサブネットを追加できます。

IPv6 アドレスの読み方

IPv6 アドレスは 128 ビットで、4 桁の 16 進数を 8 グループ並べて書きます。RFC 5952 は唯一の正規の短縮形を定めています。英字は小文字、各グループの先頭のゼロは省略し、2 つ以上連続するすべてゼロのグループのうち最も長いものを「::」に置き換えます(同じ長さなら最初のもの。ゼロのグループが 1 つだけなら短縮しません)。したがって 2001:0db8:0000:0000:0000:ff00:0042:8329 は 2001:db8::ff00:42:8329 と書きます。ログ、ドキュメント、ファイアウォールのルールでは正規形式を使い、同じアドレスがテキストとして常に一致するようにしましょう。

関連する無料ツール

  • chmod 計算 — 読み取り・書き込み・実行のチェックボックスから 8 進数のモードと chmod コマンドを求めたり、755、644、rwxr-xr-x を読み解いたりできます。
  • docker run ⇄ Compose 変換 — docker run コマンドを docker-compose.yml のサービスに、Compose のサービスを docker run に変換します。
  • ユーザーエージェント解析 — 自分のユーザーエージェントとクライアントヒントを確認したり、任意の UA 文字列をブラウザ、エンジン、OS、デバイス、CPU に分解したりできます。CSV 対応の一括モード付き。
  • 正規表現テスター — サンプルテキストに対して正規表現をテストし、マッチのハイライト、キャプチャグループ、置換のプレビューをリアルタイムで確認。無料、ブラウザ上で動作。